קישורים מומלצים

קורס CCNA
מקבץ פקודות בסיסיות ל-IOS של CISCO

הגדרות בסיסיות

 

שם לנתב

Router(config)# hostnamehostname

סיסמת enable

Router(config)#enable password password

סיסמת secret

Router(config)#enable secret password

הגדרת שם משתמש וסיסמא

Router(config)#username username password password

הגדרת telnet

Router(config)#interface line vty 0 4

הגדרת סיסמה ל - telnet

Router(config-if)#password password

אפשור כניסה דרך telnet

Router(config-if)#login

 

אפשור כניסה דרך telnet תוך שימוש ברשימת סיסמאות המוגדרות על הנתב מקומית.

אינו מתייחס לסיסמא המוגדרת על ה - line vty 0 4

Router(config-if)#login local

 

הגדרות ממשק Fastethernet/ethernet

 

Router(config)#interface FastEthernet0/0

Router(config-if)# ip address 10.213.62.251 255.255.255.0

Router(config-if)# speed 100

Router(config-if)# full-duplex

Router(config-if)# no shutdown

הגדרות ממשק loopback

Router(config)#interface Loopback0

Router(config-if)# ip address 10.213.127.4 255.255.255.255

הגדרות ממשק Serial

Router(config)#interface Serial0/0

Router(config-if)# clock rate 2000000

 

הגדרת השעון היא במקרה והכבל הינו DCE. (בדרך כלל הכבל מסתיים בממשק נקבה). ניתן לוודא את סוג הממשק ע"י הפקודה show controllers serial 0/0.

קצב השעון המקסימאלי של כבל RS-232 הינו 128K. V.35 הינו 2M.

 

הגדרת ISDN

שימוש בחייגן וב - Chap.

isdn switch-type basic-net3

!

interface BRI0

description connceted to core

no ip address

encapsulation ppp

dialer pool-member 1

isdn switch-type basic-net3

ppp authentication chap

ppp multilink

no shutdown

!

interface Dialer1

description connceted to core

ip address 1.1.1.1 255.255.255.0

encapsulation ppp

dialer remote-name core

dialer string 1111111

dialer load-threshold 1 outbound

ppp multilink

dialer pool 1

dialer-group 1

no cdp enable

ppp authentication chap

ppp chap hostname bezeq

ppp chap password cisco

!

ip route 0.0.0.0 0.0.0.0 1.1.1.2

dialer-list 1 permit ip any

 

הגדרת RIP

Router(config)#router rip

Router(config-router)#version 2

Router(config-router)#network x.x.x.x

Router(config-router)#passive-interface BRI0

הגדרת Frame-relay

interface Serial0/0

no ip address

encapsulation frame-relay

frame-relay lmi-type ansi

!

interface Serial0/0.1 point-to-point

description To-Core

bandwidth 64

ip address 1.1.1.1 255.255.255.0

frame-relay interface-dlci 16 ietf

!